Mobile App Attack 2.0 - Octavius 6

Mobile App Attack 2.0 - Octavius 6

Actions and Detail Panel

Sales Ended

Date and time

Location

Caesars Palace

Paradise, NV 89109

View map

Description

Mobile App Attack 2.0

Instructor - Sneha Rajguru

Pre-Requisites - The participants are expected to have a basic knowledge of Mobile Operating Systems. Knowledge of programming languages (Java and C, and Python for scripting) will be an added advantage to grasp things quickly.

Abstract - Mobiles Apps are the most preferred way of delivering the attacks today. Understanding the finer details of Mobile App attacks is soon becoming an essential skill for penetration testers as well as for the app developers & testers.

So, if you are an Android or an iOS User, a developer, a security analyst, a mobile pen-tester or just a mobile security enthusiast then the 'Mobile App Attack 2.0’ is of definite interest to you, as the Mobile App Attack 2.0 workshop familiarizes attendees with in-depth technical explanation of some of the most notorious mobile (Android and iOS) based vulnerabilities, ways to verify and exploit them. Along with the various Android, iOS application analysis techniques, inbuilt security schemes and teaches how to bypass those security models on both the platforms.

With live demos using intentionally crafted real-world vulnerable Android and iOS apps by the author, we shall look into the some of the common ways as to how the malicious apps bypass the security mechanisms or misuse the given permissions.

Apart from that we shall have a brief understanding of what is so special with the latest Android 7 and iOS 10 security and the relating flaws.

Required Materials - Hardware Requirements:

  • Minimum 4GB RAM and more than 20 GB Free Hard Disk Space

  • Android device ( >=2.3)

  • iPhone/iPad >= 7.1.2

  • (preferable Rooted/Jailbreak)

Software Requirements:

  • Windows 7/8

  • *Nix

  • Mac OS X 10.5

  • Administrative privileges on your machines

  • Virtualbox or VMPlayer

  • SSH Client

  • Xcode 6 or higher

  • ADB

  • Android Studio 1.3 or higher

  • Android SDK